American Express Outage
Incident Report for Clover Sport
Resolved
The American Express outage has been resolved on their side. Normal operations for Amex card payments should be restored. Thank you.
Posted Nov 18, 2022 - 21:59 CST
Investigating
Currently American Express is experiencing an outage, directly affecting this particular card type at Clover Sport. All other card types are functioning as expected. We will update the status of this outage here. Thank you for your patience while we work through this issue.
Posted Nov 18, 2022 - 19:26 CST