Seven Shifts - Sales and Labor data is not being uploaded into app
Incident Report for Clover Sport
Resolved
This incident has been resolved.
Posted Aug 31, 2022 - 13:06 CDT
Investigating
Sales and Labor data is not being uploaded into Seven Shifts app in some locations.
Posted Aug 11, 2022 - 10:22 CDT
This incident affected: Bypass Services (Login).